DC-SSR Output | Outputs per module | 8
 | DC-SSR Type | Normal Open
 | Load Voltage Rating | 3 to 30 VDC
 | Off-state Leakage Current | 0.1mA (at 30VDC) max.
 | Load Current | 1.0A max.
 | Operate Time | 1mS max.
 | Release Time | 1mS max.
 | Dielectric Strength | 2500VRMS
LED Display | 1 LED as Power/Communication indicator 8 LEDs as DC-SSR output indicators
Power Consumption | Maximum : 0.7W

I-87066 Pin Assignment
Terminal Number | Pin Name
1 | SSR0+
2 | SSR0-
3 | SSR1+
4 | SSR1-
5 | -
6 | SSR2+
7 | SSR2-
8 | SSR3+
9 | SSR3-
10 | -
11 | SSR4+
12 | SSR4-
13 | SSR5+
14 | SSR5-
15 | -
16 | SSR6+
17 | SSR6-
18 | SSR7+
19 | SSR7-
20 | -

I-87066 Block Diagram

Output Type ON State
LED ON
Readback as 1 		OFF State
LED OFF
Readback as 0
DC-SSR Output
Load current On I-87066 DC-SSR Output
Load current Off I-87065 DC-SSR Output

I-87066 Dimention

Configuration | Default Setting | Description
Type | 40 | Digital Input/Output
Baudrate | 0A | 115200 bps
Format | 00 | CheckSum disable

Back to Previous Page


Command | Description
%AANNTTCCFF | Set Module Configuration
$AA2 | Read module configuration
$AA4 | Read synchronized digital input/output status
$AA5 | Read reset status
$AA6 | Read digital input/output status
$AAF | Read firmware version
$AAM | Read module name
#** | Synchronized sampling
#AABBDD | Digital output
@AA | Read digital input/output status
@AA(Data) | Set digital outputs
~AA0 | Read module status
~AA1 | Reset module status
~AA2 | Read host watchdog timeout setting
~AA3ETT | Set host watchdog timeout setting
~AA4S | Read PowerOn Value / Safe Value
~AA5S | Set PowerOn Value / Safe Value
~AAO(Name) | Set module name


Command | %AANNTTCCFF
Description | Set Module Configuration
Syntax %AANNTTCCFF[CHK](cr)
% | a delimiter character
AA | address of setting module (00 to FF)
NN | new address for setting module (00 to FF)
TT | new type for setting module
CC | new baudrate for setting module. It is needed to short INIT* to ground while change baudrate.
FF | new format for setting module. It is needed to short INIT* to ground while change checksum setting.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command. While change baudrate or checksum setting without short INIT* to ground, the module will return invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | %0102080600
Response | !02
Description | Change address from 01 to 02, return success.
Command | %0202080602
Response | !02
Description | Change data format from 00 to 02, return success.
Reference $AA2
Type Table
Baudrate Table
Format Table
INIT* pin Operation


Command | $AA2
Description | Read module configuration
Syntax $AA2[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
2 | command for reading configuration
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AATTCCFF[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
TT | current type setting
CC | current baudrate setting
FF | current format setting
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $012
Response | !01080600
Description | Read configuration of address 01, return success.
Reference %AANNTTCCFF
Type Table
Baudrate Table
Format Table
INIT* pin Operation


Command | $AA4
Description | Read synchronized digital input/output status
Syntax $AA4[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
4 | command for reading synchronized digital input/output status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !S(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
S | status of synchronized data 1 = first read 0 = the data has been readed
(Data) | synchronized digital input/output status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $014
Response | !10F0000
Description | Read synchronized digital input/output status of address 01 channel status, response first read and synchronized data 0F00.
Reference #**


Command | $AA5
Description | Read reset status
Syntax $AA5[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
5 | command for read status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AAS[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
S | reset status 1 = the module is been reseted, and the status is reset to 0 after read 0 = the module is not been reseted
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $015
Response | !011
Description | Read reset status of address 1, response the module is reseted before read.
Command | $015
Response | !010
Description | Read reset status of address 1 again, response the module is not reseted before read.
Reference


Command | $AA6
Description | Read digital input/output status
Syntax $AA6[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
6 | command for reading digital input/output status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | digital input/output status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $016
Response | !0F0000
Description | Read digital input/output status of address 01 channel status, response 0F00.
Reference @AA


Command | $AAF
Description | Read firmware version
Syntax $AAF[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
F | command for reading firmware version
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Version)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Version) | firmware version
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01F
Response | !01B1.0
Description | Read address 01 firmware version, response version is "B1.0".


Command | $AAM
Description | Read module name
Syntax $AAM[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
M | command for reading module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Name)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Name) | module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01M
Response | !0187017
Description | Read address 01 module name, response module name is "87017".
Reference ~AAO(Name)


Command #**
Description | Synchronized sampling
Syntax #**[CHK](cr)
# | a delimiter character
** | command for all modules
[CHK] | 2 characters of checksum
(cr) | Character Return(0x0D) for denote the end of command
Response | No response
Example
Command | #**
Response | No Response
Reference | $AA4


Command | #AABBDD
Description | Digital output
Syntax #AABBDD[CHK](cr)
# a delimiter character
AA | address of output module (00 to FF)
BBDD | output command and parameter
BB | Description
00 or OA | Output DD(00 to FF) to channel 0 to 7
0B | Output DD(00 to FF) to channel 8 to 15
10 or A0 | Set(DD=01) or Reset(DD=00) to channel 0
11 or A1 | Set(DD=01) or Reset(DD=00) to channel 1
12 or A2 | Set(DD=01) or Reset(DD=00) to channel 2
13 or A3 | Set(DD=01) or Reset(DD=00) to channel 3
14 or A4 | Set(DD=01) or Reset(DD=00) to channel 4
15 or A5 | Set(DD=01) or Reset(DD=00) to channel 5
16 or A6 | Set(DD=01) or Reset(DD=00) to channel 6
17 or A7 | Set(DD=01) or Reset(DD=00) to channel 7
B0 | Set(DD=01) or Reset(DD=00) to channel 8
B1 | Set(DD=01) or Reset(DD=00) to channel 9
B2 | Set(DD=01) or Reset(DD=00) to channel 10
B3 | Set(DD=01) or Reset(DD=00) to channel 11
B4 | Set(DD=01) or Reset(DD=00) to channel 12
B5 | Set(DD=01) or Reset(DD=00) to channel 13
B6 | Set(DD=01) or Reset(DD=00) to channel 14
B7 | Set(DD=01) or Reset(DD=00) to channel 15
[CHK] | 2 characters of checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | >[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Ignored Command | ![CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command.
! | delimiter for ignore the output command. The module's host watchdog timeout flag is set, and the output is set to SafeValue.
AA | address of response module (00 to FF)
[CHK] | 2 characters of checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | #0100FF
Response | >
Description | Output value to FF, return success.
Reference ???


Command | @AA
Description | Read digital input/output status
Syntax @AA[CHK](cr)
@ | a delimiter character
AA | address of reading module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | >(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | digital input/output status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | @01
Response | !0F00
Description | Read digital input/output status of address 01 channel status, response 0F00.
Reference $AA6


Command | @AA(Data)
Description | Set digital outputs
Syntax @AA(Data)[CHK](cr)
@ a delimiter character
AA | address of setting module (00 to FF)
(Data) | digital output value
Total Output Channels of Module | (Data)
less than 4 channels | 0 to F
5 to 8 channels | 00 to FF
9 to 16 channels | 0000 to FFFF
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | >[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | @010000
Response | >
Description | Set digital output to 0000 of address 01, response success.
Reference @AA
#AABBDD
$AA6


Command | ~AA0
Description | Read module status
Syntax ~AA0[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
0 | command for reading module status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AASS[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
SS | module status. The status is stored in the EEPROM of module, and may reset by command ~AA1. 00 = host watchdog status is clear 04 = host watchdog status is set
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~010
Response | !0100
Description | Read module status of address 01, response 00
Reference ~AA1


Command | ~AA1
Description | Reset module status
Syntax ~AA1[CHK](cr)
~ | a delimiter character
AA | address of setting module (00 to FF)
1 | command for reset module status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~011
Response | !01
Description | Reset module status of address 01, response success
Reference ~AA0


Command | ~AA2
Description | Read host watchdog timeout setting
Syntax ~AA2[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
2 | command for reading host watchdog setting
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AAETT[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
E | enable/disable flag. 0 = Host watchdog is disabled 1 = Host watchdog is enabled
TT | host watchdog timeout interval in hexdecimal. 01 is 0.1 second, 02 is 0.2 second and FF is 25.6 seconds.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~012
Response | !010FF
Description | Read host watchdog setting of address 01, response host watchdog is disabled, and the timeout interval is 25.6 seconds.
Reference ~AA3ETT


Command | ~AA3ETT
Description | Set host watchdog timeout setting
Syntax ~AA3ETT[CHK](cr)
~ | a delimiter character
AA | address of settting module (00 to FF)
3 | command for set host watchdog setting
E | enable/disable flag. 0 = Disable host watchdog 1 = Enable host watchdog
TT | host watchdog timeout interval in hexdecimal. 01 is 0.1 second, 02 is 0.2 second and FF is 25.6 seconds.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~013164
Response | !01
Description | Set host watchdog setting, enable host, time out interval is 10.0 seconds, to address 01, response success.
Reference ~AA2


Command | ~AA4S
Description | Read PowerOn Value / Safe Value
Syntax ~AA4S[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
4 | command for read PowerOn Value / Safe Value
S | P = Read PowerOn Value S = Read Safe Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | PowerOn Value / Safe Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~014P
Response | !010000
Description | Read PowerOn Value of address 01, response 0000.
Reference ~AA5S


Command | ~AA5S
Description | Set PowerOn Value / Safe Value
Syntax ~AA5S[CHK](cr)
~ | a delimiter character
AA | address of setting module (00 to FF)
5 | command for store current output as PowerOn Value / Safe Value
S | P = Set PowerOn Value S = Set Safe Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~015P
Response | !01
Description | Set PowerOn Value of address 01, response success.
Reference ~AA4S


Command | ~AAO(Name)
Description | Set module name
Syntax ~AAO(Name)[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
O | command for setting module name
(Name) | module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~01O87018
Response | !01
Description | Set address 01 module name as "87018", response success.
Reference $AAM


Baudrate Table
Configuration Code | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 0A
Baudrate(bps) | 1200 | 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200


Command/Response String and Checksum
Command/Response Format
Command Format | (Leading)(Address)(Command)[CHK](cr)
Response Format | (Leading)(Address)(Response)[CHK](cr)

(Leading) | Leading character, like ~, $, #, @, %, !, ?, >.
(Address) | Address of specificed module, from 00 to FF. For some command like #**, the address is ** for all modules.
(Command/Response) | Command with parameters or response with data.
[CHK] | 2-character checksum. If the CheckSum is disabled, no [CHK] here.
(cr) | end-of-command character, character return(0Dh)

Calculate Checksum
  1. Calculate ASCII sum of all characters of (Leading), (Address) and (Command)(or (Response)).
  2. Mask the sum of string with 0ffh, or said only take the last 2 digits of the hex value of the sum.
    For example, if the sum is 01BCh, take the "BC" as the [CHK].

Example
  • Command string : $012
    1. Sum of string = `$'+`0'+`1'+`2' = 24h+30h+31h+32h = B7h

    2. The checksum is B7h, and [CHK] = "B7"

    3. Command string with checksum : $012B7(cr)

  • Response string : !01070600
    1. Sum of string : `!'+`0'+`1'+`0'+`7'+`0'+`6'+`0'+`0' =
      21h + 30h + 31h + 30h + 37h + 30h + 36h + 30h + 30h = 1AFh

    2. The checksum is AFh, and [CHK] = "AF"

    3. Response string with checksum : !01070600AF
      4. (cr)


Format Selection
Analog Input Module | I-87013, I-87015, I-87015T, I-87017 , I-87018
Analog Output Module | I-87022, I-87026, I-87024
Digital Input/Output Module | I-870xx
Counter/Frequency Input Module | I-87082

Back to Previous Page

Format Table for Analog Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Filter Selection | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Data Format Selection

Filter Selection | 0 = 60Hz rejection
 | 1 = 50Hz rejection
 | This setting is reserved for the I-87015/I-87015T and should be zero.
CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Data Format Selection | 00 = Engineer Unit Format
 | 01 = % of FSR Format
 | 10 = 2's Complement Hexdecimal Format
 | 11 = Ohms in Engineer Unit Format For I-87013 Only

Example
Format Code | Description
00 | 60Hz rejection, CheckSum disabled, engineer unit format
41 | 60Hz rejection, CheckSum enabled, % of FSR format
82 | 50Hz rejection, CheckSum disabled, 2's complement hexdecimal format

Back to Previous Page

Format Table for Analog Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Slew Rate Control |  |  |  | Data Format Selection

CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Slew Rate Control ( For 87022/26 ) | Set to 0.
Slew Rate Control ( For 87024 ) | 0000 = Immediate output
 | 0001 = 0.0625V/Second or 0.125mA/Second
 | 0010 = 0.125V/Second or 0.25mA/Second
 | 0011 = 0.25V/Second or 0.5mA/Second
 | 0100 = 0.5V/Second or 1.0mA/Second
 | 0101 = 1.0V/Second or 2.0mA/Second
 | 0110 = 2.0V/Second or 4.0mA/Second
 | 0111 = 4.0V/Second or 8.0mA/Second
 | 1000 = 8.0V/Second or 16.0mA/Second
 | 1001 = 16.0V/Second or 32.0mA/Second
 | 1010 = 32.0V/Second or 64.0mA/Second
 | 1011 = 64.0V/Second or 128.0mA/Second
 | 1100 = 128.0V/Second or 256.0mA/Second
 | 1101 = 256.0V/Second or 512.0mA/Second
 | 1110 = 512.0V/Second or 1024.0mA/Second
 | 1111 = 1024.0V/Second or 2048.0mA/Second
Data Format Selection | 00 = Engineer Unit Format

Example
Format Code | Description
00 | CheckSum disabled, immediate output, engineer unit format
44 | CheckSum enabled, 0.0625V/Second or 0.125mA/Second output slew rate, engineer unit format
10 | CheckSum disabled, 0.5V/Second or 0.25mA/Second output slew rate, engineer unit format

Back to Previous Page

Format Table for Digital Input/Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Format Table for Counter/Frequency Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Frequency Gate Time | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Frequency Gate Time 0 = 0.1 Second
1 = 1.0 Second


Type Selection
Module | Available Type
I-87013 | RTD Input
I-87015 | RTD Input
I-87015_T | Thermister Input
I-87017 | mV, V or Current Input
I-87018 | mV, V or Current Input Thermocouple Input
I-87022 | Analog Output
I-87024 | Analog Output
I-87026 | Analog Output
I-870xx | Digital Input/Output
I-87082 | Counter/Frequency Measurement

Back to Previous Page

Type 00 to 06 Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
00 | -15mV to +15mV | Engineer Unit | +15.000 | +00.000 | -15.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
01 | -50mV to +50mV | Engineer Unit | +50.000 | +00.000 | -50.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
02 | -100mV to +100mV | Engineer Unit | +100.00 | +000.00 | -100.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
03 | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
04 | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
05 | -2.5V to +2.5V | Engineer Unit | +2.5000 | +0.0000 | -2.5000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
06 | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Type 08 to 0D Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
08 | -10V to +10V | Engineer Unit | +10.000 | +00.000 | -10.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
09 | -5V to +5V | Engineer Unit | +5.0000 | +0.0000 | -5.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0A | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0B | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0C | -150mV to +150mV | Engineer Unit | +150.00 | +000.00 | -150.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0D | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Thermocouple Type Definition
Type Code | Thermocouple Type | Data Format | Max Value | Min Value
0E | J Type | Engineer Unit | +760.00 | -210.00
 |  | % of FSR | +100.00 | -027.63
 |  | 2's Complement HEX | 7FFF | DCA2
0F | K Type | Engineer Unit | +1372.0 | -0270.0
 |  | % of FSR | +100.00 | -019.68
 |  | 2's Complement HEX | 7FFF | E6D0
10 | T Type | Engineer Unit | +400.00 | -270.00
 |  | % of FSR | +100.00 | -067.50
 |  | 2's Complement HEX | 7FFF | A99A
11 | E Type | Engineer Unit | +1000.0 | -0270.0
 |  | % of FSR | +100.00 | -027.00
 |  | 2's Complement HEX | 7FFF | DD71
12 | R Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
13 | S Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
14 | B Type | Engineer Unit | +1820.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
15 | N Type | Engineer Unit | +1300.0 | -0270.0
 |  | % of FSR | +100.00 | -020.77
 |  | 2's Complement HEX | 7FFF | E56B
16 | C Type | Engineer Unit | +2320.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
17 | L Type | Engineer Unit | +800.00 | -200.00
 |  | % of FSR | +100.00 | -025.00
 |  | 2's Complement HEX | 7FFF | E000
18 | M Type | Engineer Unit | +100.00 | -200.00
 |  | % of FSR | +050.00 | -100.00
 |  | 2's Complement HEX | 4000 | 8000
19 | L Type DIN43710 | Engineer Unit | +900.00 | -200.00
 |  | % of FSR | +100.00 | -022.22
 |  | 2's Complement HEX | 7FFF | E38F

Thermocouple Input Type Over/Under Range Response
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000

Back to Previous Page

RTD Type Definition
Type Code | RTD Type | Data Format | Max Value | Min Value
20 | Platinum 100 a = 0.00385 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +138.50 | +060.25
21 | Platinum 100 a = 0.00385 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +138.50 | +100.00
22 | Platinum 100 a = 0.00385 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +175.84 | +100.00
23 | Platinum 100 a = 0.00385 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +313.59 | +100.00
24 | Platinum 100 a = 0.003916 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +139.16 | +059.58
25 | Platinum 100 a = 0.003916 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +139.16 | +100.00
26 | Platinum 100 a = 0.003916 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +177.13 | +100.00
27 | Platinum 100 a = 0.003916 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +317.28 | +100.00
28 | Nickel 120 -80 to 100 degree Celsius | Engineer Unit | +100.00 | -080.00
 |  | % of FSR | +100.00 | -080.00
 |  | 2's complement HEX | 7FFF | 999A
 |  | Ohm | +200.64 | +120.60
29 | Nickel 120 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +200.64 | +120.60
2A | Platinum 1000 a = 0.00385 -200 to 600 degree Celsius | Engineer Unit () | +600.00 | -200.00
 |  | % of FSR | +100.00 | -033.33
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +3137.1 | +0185.2
2B | Cu 100 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +163.17 | +091.56
2C | Cu 100 a = 0.00421 0 to 200 degree Celsius | Engineer Unit () | +200.00 | -000.00
 |  | % of FSR | +100.00 | -000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +167.75 | +090.34
2D | Cu 1000 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +1631.7 | +0915.6

Note :
1.Type 2B, 2C and 2D are only used in the I-87015

RTD Input Type Over/Under Range Response
For I-87013 |  |
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000
For I-87015 |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Thermistor Type Definition
60 | Precon -- ST-A3 -30 to 240 degree Fahrenheit | Engineer Unit | +240.00 | -030.00
 |  | % of FSR | +100.00 | -012.50
 |  | 2's complement HEX | 7FFF | F000
 |  | Ohm | +000539.4 | +173600.0
61 | Type u Fenwell -50 to 150 degree Celisus | Engineer Unit | +150.00 | -050.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +000037.2 | +134020.0
62 | Type u Fenwell 0 to 150 degree Celisus | Engineer Unit | +150.00 | -000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +000037.2 | +006530.0

Thermistor Input Type Over/Under Range Response
For I-87015T |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Analog Output Type Definition
Type Code | Output Range | Data Format | Max Value | Min Value
30 | 0 to 20mA | Engineer Unit | +20.000 | +00.000
31 | 4 to 20mA | Engineer Unit | +20.000 | +04.000
32 | 0 to 10V | Engineer Unit | +10.000 | +00.000
33 | -10 to 10V | Engineer Unit | +10.000 | -10.000
34 | 0 to 5V | Engineer Unit | +05.000 | +00.000
35 | -5 to 5V | Engineer Unit | +05.000 | -05.000

Back to Previous Page

I-87022 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000

Back to Previous Page

I-87026 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000

Back to Previous Page

I-87022 and I-87026 Slew Rate Control Definition (S)

Slew Rate Control Code
( For I-87022/26 ) 		0 = Immediate output
1 = 0.0625V/Second or 0.125mA/Second
2 = 0.125V/Second or 0.25mA/Second
3 = 0.25V/Second or 0.5mA/Second
4 = 0.5V/Second or 1.0mA/Second
5 = 1.0V/Second or 2.0mA/Second
6 = 2.0V/Second or 4.0mA/Second
7 = 4.0V/Second or 8.0mA/Second
8 = 8.0V/Second or 16.0mA/Second
9 = 16.0V/Second or 32.0mA/Second
A = 32.0V/Second or 64.0mA/Second
B = 64.0V/Second or 128.0mA/Second
C = 128.0V/Second or 256.0mA/Second
D = 256.0V/Second or 512.0mA/Second
E = 512.0V/Second or 1024.0mA/Second

Back to Previous Page

Digital Input/Output Type Definition
Type Code | Description
40 | Digital Input/Output

Counter/Frequency Type Definition
Type Code | Description
50 | Counter Mode
51 | Frequency Measurement