I-8054 User's Manual

Digital Output | Output Channel | 8
 | Output Type | Isolated open-collector
 | Max load current | 375mA per channel
 | Load voltage | +5V to +30VDC
 | Isolation Voltage | 3750 Vrms
Digital Input | Input Channel | 8
 | Input Type | Isolated digital input with common power
 | ON State | Input voltage < 1V
 | OFF State | Input voltage > 3.5V
 | Input Impedance | 3K Ohms
 | Isolation Voltage | 3750 Vrms
LED Display | 1 LED as Power/Communication indicator 8 LEDs as digital output indicators 8 LEDs as digital input indicators
Power Consumption | Typical : 0.5W Maximum : 0.7W
Note | 8054 : Internal Parallel Bus

I-8054 Pin Assignment
Terminal Number | Pin Name
1 | DI.PWR
2 | DI0
3 | DI1
4 | DI2
5 | DI3
6 | DI4
7 | DI5
8 | DI6
9 | DI7
10 | DO0
11 | DO1
12 | DO2
13 | DO3
14 | DO4
15 | DO5
16 | DO6
17 | DO7
18 | DO.GND
19 | DO.GND
20 | DO.PWR

I-8054 Block Diagram
Input Type ON State
LED ON
Readback as 1 		OFF State
LED OFF
Readback as 0
Relay Contact
Relay Close I-8054 Digital Input
Relay Open I-8054 Digital Input
TTL/CMOS Logic
Logic Low I-8054 Digital Input
Logic High I-8054 Digital Input
Open Collector
Open Collector On I-8054 Digital Input
Open Collector Off I-8054 Digital Input

Output Type ON State
LED ON
Readback as 1 		OFF State
LED OFF
Readback as 0
Drive Relay
Relay On I-8054 Open Collector Output
Relay Off I-8054 Open Collector Output
Resistance Load
Current On I-8054 Open Collector Output
Currnet Off I-8054 Open Collector Output

I-8054 Dimention

Back to Previous Page


I-8054 Slave Command Sets

Command | Description
$AASi6 | Read Digital Input OR Read Back Digital Output
$AASiM | Read Digital Output Channel Masking Status
#AASiBB(data) | Set Digital Output
~AASi4P | Reads Power On Value
~AASi4PS | Reads Enable/Disable Status Of Power On Value
~AASi5P | Enables Power On Value
~AASi5PC | Disables Power On Value


I-8000 Command Sets

Command
$AASi6
Description
This command for readback the Digital Output module
value and read the Digital Input module value
in the specified Slot of the I-8000 system.
Syntax
$AASi6[CHK](cr)
$ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
6 | Command for read data
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response
Valid Command
!0D0E00[CHK](cr) for 8 bits DIO modules
!DD0000[CHK](cr) for 8 bits (or less than 8 bits) DO modules
!EE0000[CHK](cr) for 8 bits (or less than 8 bits) DI modules
!DDEE00[CHK](cr) for 16 bits DIO modules
!DDDD00[CHK](cr) for 16 bits DO modules
!EEEE00[CHK](cr) for 16 bits DI modules
!DDDDEEEE[CHK](cr) for 32 bits DIO modules
!DDDDDDDD[CHK](cr) for 32 bits DO modules
!EEEEEEEE[CHK](cr) for 32 bits DI modules
Invalid Command ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
D | 4 bits output value (0~Fh)
E | 4 bits input value (0~Fh)
DD | 8 bits output value (00~FFh)
EE | 8 bits input value (00~FFh)
DDDD | 16 bits output value (0000~FFFFh)
EEEE | 16 bits input value (0000~FFFFh)
DDDDDDDD | 32 bits output value (00000000~FFFFFFFFh)
EEEEEEEE | 32 bits input value (00000000~FFFFFFFFh)
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | $01S16
Response | !0155AA00
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 8,10,12,14 are ON and the channels 9,11,13,15 are OFF. The third 2-character AAh(10101010) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF.
Command | $01S16
Response | !01550000
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF.
Modules
I-8040,I-8041,I-8042,I-8050, I-8051, I-87051, I-8052, I-87052
, I-8053 ,I-87053, I-8054, I-87054, I-8055, I-87055, I-8056
,I-8057, I-87057, I-8058, I-8060, I-8063, I-87063
,I-8064, I-87064, I-8065, I-87065, I-8066, I-87066
,I-8068, I-87068


Command
$AASiM
Description
This command for read the Digital Output module channel masking status in the specified Slot of the I-8000 system.
Syntax
$AASiM[CHK](cr)
$ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
M | Command to read masking status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response

Valid Command | !AADDDD[CHK](cr) for 16 bits DO modules !AADD[CHK](cr) for 8 bits DO or 16 bits DIO modules
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
DDDD | 16 bits channel masking value of the DO module
DD | 8 bits channel masking value of the DO or DIO module
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | $01S16
Response | !0155AA
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF. The third 2-character AAh(10101010) indicate the I/O module channels 8,10,12,14 are ON and the channels 9,11,12,14 are OFF.
Command | $01S16
Response | !015500
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF.
Modules
I-8050, I-8051, I-87051, I-8052, I-87052, I-8053,
I-87053, I-8054, I-87054, I-8055, I-87055, I-8056,
I-8057, I-87057, I-8058, I-8060, I-8063, I-87063,
I-8064, I-87064, I-8065, I-87065, I-8066, I-87066,
I-8068, I-87068


Command
#AASiBB(data)
Description
This command send the Value to the Digital output module in the specified channel and slot of the I-8000 system.
Syntax
#AASiBB(data)[CHK](cr)
# | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
BB | If BB=00 that all channel will be set. If BB = 1B that 'B' channel will be set. The 'B' range from 0 to F.
(data) | 2-characters or 4-characters HEX for digital output value. For single channel output the data will be 2-characters. The first character is always 0. The second character is ether 0 or 1.0 => OFF,1 => ON. For all channel output the data will be 2-characters HEX for less than or equal 8 bits, 4-characters for 16 bits and greater than 8 bits . The data bit is correspond to the output module channel.
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response

Valid Command | >[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Note
If the any channel of digital output module (*1) is configure for the analog input alarms then this command is no effect to the specified channel . The channel is used for analog input alarms always can not configure again unless it is disconnect.
Refer to : Analog Input Alarm
 (*1) For digital output modules not support analog input alarm are :
1. i-8041, i-87041, i-87042, i-8050
Example

Command | #01S31101
Response | >(cr)
Description | The example is for single channel. The Digital output Module in slot 3 and channel 1(1h) of the I-8000 system at address 01h will be set to ON. This example just for output module channel number is less than or equal 8.
Command | #01S300AA55(cr)
Response | >(cr)
Description | The example is for All channels. The Digital output Module in slot 3 and channels 0,2,4,6,(55h),9,11,13,15(AAh) of the I-8000 system at address 01h will be set to ON. The other channels 1,3,5,7,8,10,12,14 are set to OFF. This example just for output module channel number is greater than 8.
Command | #01S30055(cr)
Response | >(cr)
Description | The example is for All channels. The Digital output Module in slot 3 and channels 0,2,4,6(55h) of the I-8000 system at address 01h will be set to ON. The other channels 1,3,5,7 are set to OFF. This example just for output module channel number is less than or equal 8.
Modules
I-8050, I-8051, I-87051, I-8052, I-87052, I-8053,
I-87053, I-8054, I-87054, I-8055, I-87055, I-8056,
I-8057, I-87057, I-8058, I-8060, I-8063, I-87063,
I-8064, I-87064, I-8065, I-87065, I-8066, I-87066,
I-8068, I-87068, I-8077


Command
~AASi4P
Description
Reads power on value of DO or DIO module in specific slot of the I-8000 system.
Syntax
~AASi4P[CHK](cr)
~ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
4P | command to read power on value
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response

Valid Command | !AAEE0000[chk](cr) for 8 bits or less than 8 bits DO/DIO module !AAEEEE00[chk](cr) for 16 bits DO/DIO module !AAEEEEEEEE[chk](cr) for 32 bits DO/DIO module
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | address number of the I-8000 system
EE | 8 bits power on DO value (00~FFh)
EEEE | 16 bits power on DO value (0000~FFFFh)
EEEEEEEE | 32 bits power on DO value (00000000~FFFFFFFFh)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | ~01S74P
Response | !01130000(cr)
Description | Power on value of slot7 is 1300h for 16 channels DO/DIO module. Power on value of slot7 is 13h for 8 channels (or less than 8 channels) DO/DIO module.
Modules
DO or DIO modules


Command
~AASi4PS
Description
Reads enable/disable status of power on value of DO or DIO module in specific slot of the I-8000 system.
Syntax
~AASi4PS[CHK](cr)
~ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
4 | command for read PowerOn Value / Safe Value
PS | power on value status
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response

Valid Command | !AAS[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | address number of the I-8000 system
S | power on value status. S: 0= disable, 1= enable
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Note
If any channel of the DO or DIO module is configure for the analog input alarms then this command is no effect to the specified channel . The channel is used for analog input alarms always can not configure again unless it is disconnect.
Refer to : Analog Input Alarm
Example

Command | ~01S74PS
Response | !010(cr)
Description | Power on value of DO or DIO module in slot7 of the I-8000 system (address=01h) is disabled.
Modules
DO or DIO modules


Command
~AASi5P
Description
Enables power on value of DO or DIO module in specific slot of the I-8000 system. The current DO status is set to power on value.
Syntax
~AASi5P[CHK](cr)
~ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
5P | command to set and enable power on value
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response

Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | address number of the I-8000 system.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | ~01S75P
Response | !01(cr)
Description | Enables power on value of DO or DIO module in slot7 of the I-8000 system (address=01h) and set the current DO status as power on value.
Modules
DO or DIO modules


Command
~AASi5PC
Description
Disables power on value of DO or DIO module in specific slot of the I-8000 system.
Syntax
~AASi5PC[CHK](cr)
~ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
5PC | command to disable power on value
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response

Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | address number of the I-8000 system
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | ~01S75PC
Response | !01(cr)
Description | Disables power on value of DO or DIO module in slot7 of the I-8000 system (address=01h).
Modules
DO or DIO modules


Command | $AASiCjAH
Description | Read the specified channel and slot alarm mode in the I-8000 system.
Syntax $AASiCjAH[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
A | Command for Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0AH
Response | !01L
Description | The channel 0 and slot 3 in the I-8000 system at address 01h that the high alarm mode is setting with latching mode.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjAHCSkCn
Description | This command set the specified channel and slot input High/Low Alarm to the specified digital output channel and slot in the I-8000 system.
Syntax $AASiCjAHCSkCn[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
A | Command for Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
C | The connection of Alarm
Sk | Specified the slot number of digital output module. k = 0 to 3(4 slots) or k = 0 to 7(8 slots)
Cn | Specified the channel number of digital output module. n = 0 to F
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0CLCS0C5
Response | !01
Description | When slot 3, channel 0 Analog input occurred low alarm then set the slot 0, channel 5 digital output in the I-8000 at address 01h. The response indicates the command is valid.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjAHES
Description | This command set the specified channel and slot with Enabled or Disabled Alarm in the I-8000 system.
Syntax $AASiCjAHES[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
A | Command for Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
E | command for enabled/disabled alarm function
S | E=Enabled, D=Disabled
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0AHEE
Response | !01
Description | This example set the high alarm enabled for the channel 0 and slot 3 in the I-8000 system at address 01h The response indicates the command is valid.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjAHS
Description | This command set the specified channel and slot alarm mode of analog input module in the I-8000 system.
Syntax $AASiCjAHS[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
A | Command for Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
S | Alarm mode, M = Momentary, L = Latching
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0AHL
Response | !01
Description | This example set the high alarm with latching mode for the channel 0 and slot 3 in the I-8000 system at address 01h. The response indicates the command is valid.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjAHU(data)
Description | This command set the specified channel and slot with High/Low Alarm Limit in the I-8000 system.
Syntax $AASiCjAHU(data)[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
A | Command for Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
U | command for set alarm limit value
(data) | Alarm limit by engineering unit
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0ALU+001.00
Response | !01
Description | This example set the channel 0,slot 3 low alarm limit with +1 C deg in the I-8000 system at address 01h The response indicates the command is valid.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjCH
Description | Clear the specified channel and slot High/Low Latching Alarm in the I-8000 system.
Syntax $AASiCjCH[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
C | Command for clear latching Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0CH
Response | !01
Description | This example clear the high alarm for the channel 0 and slot 3 in the I-8000 system at address 01h The response indicates the command is valid.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjRHC
Description | Read the specified analog input channel and slot High/Low alarm connection in the I-8000 system.
Syntax $AASiCjRHC[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
R | Command for Read Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
C | The connection of Alarm
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AASkCn[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
Sk | Specified the slot number of digital output module. k = 0 to 3(4 slots) or k = 0 to 7(8 slots)
Cn | Specified the channel number of digital output module. n = 0 to F
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0RLC
Response | !01S0C5
Description | The low alarm connection for the analog input channel 0, slot 3 is setting with channel 5, slot 0 in the I-8000 system at address 01h.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjRHU
Description | Read the specified analog input channel and slot High/Low Alarm Limit in the I-8000 system.
Syntax $AASiCjRHU[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
R | Command for Read Alarm Function
H | High/Low alarm, H = High alarm, L = Low alarm
U | command for read alarm limit value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
(data) | Alarm limit by engineering unit
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0ALU
Response | !01+001.00
Description | This example Read the analog input module low alarm limit from channel 0,slot 3 in the I-8000 system at address 01h is +1 C deg.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


Command | $AASiCjS
Description | Read the specified analog input channel and slot alarm status in the I-8000 system.
Syntax $AASiCjS[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number.
S | Command for Read Alarm Status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AAHL[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
H | High Alarm,¡¦1¡¦= Alarm happen,¡¦0¡¦=no alarm
L | Low Alarm,¡¦1¡¦= Alarm happen,¡¦0¡¦=no alarm
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S3C0S
Response | !0110
Description | This example Read the analog input module alarm status from channel 0,slot 3 in the I-8000 system at address 01h that has been happen high alarm.
Modules | I-87013, I-87016, I-8017H, I-87017, I-87018


I-8000Series User's Manual

On-Line User's Manual
Analog Input Alarm
Command | Description
$AASiCjAHS | Set Alarm Mode
$AASiCjAH | Read Alarm Mode
$AASiCjAHES | Enable/Disable Alarm Function
$AASiCjCH | Clear Latch Alarm
$AASiCjAHCSkCn | Set Alarm Connection
$AASiCjRHC | Read Alarm Connection
$AASiCjAHU(data) | Set Alarm Limit Value
$AASiCjRHU | Read Alarm Limit Value
$AASiCjS | Read Alarm Status


Command/Response String and Checksum
Command/Response Format
Command Format | (Leading)(Address)(Command)[CHK](cr)
Response Format | (Leading)(Address)(Response)[CHK](cr)

(Leading) | Leading character, like ~, $, #, @, %, !, ?, >.
(Address) | Address of specificed module, from 00 to FF. For some command like #**, the address is ** for all modules.
(Command/Response) | Command with parameters or response with data.
[CHK] | 2-character checksum. If the CheckSum is disabled, no [CHK] here.
(cr) | end-of-command character, character return(0Dh)

Calculate Checksum
  1. Calculate ASCII sum of all characters of (Leading), (Address) and (Command)(or (Response)).
  2. Mask the sum of string with 0ffh, or said only take the last 2 digits of the hex value of the sum.
    For example, if the sum is 01BCh, take the "BC" as the [CHK].

Example
  • Command string : $012
    1. Sum of string = `$'+`0'+`1'+`2' = 24h+30h+31h+32h = B7h

    2. The checksum is B7h, and [CHK] = "B7"

    3. Command string with checksum : $012B7(cr)

  • Response string : !01070600
    1. Sum of string : `!'+`0'+`1'+`0'+`7'+`0'+`6'+`0'+`0' =
      21h + 30h + 31h + 30h + 37h + 30h + 36h + 30h + 30h = 1AFh

    2. The checksum is AFh, and [CHK] = "AF"

    3. Response string with checksum : !01070600AF
      4. (cr)


I-8000Series User's Manual

On-Line User's Manual Master And Slave
Item | Description
Slave In the slave mode the I-8000 Series can be controlled by the host machine as a distributed I/O front ends.It receive the command from the host by the comunication port, then explain the command and execute the command. So it waste the time to receive command,explain command and echo result.It can't be use for the control that must take care of the timing.
It advantage is easy to use, user doesn't take care of the hardware structure. The user only need to know how the command work.
Master | In the Master mode the I-8000 Series can operate as an embedded application. The user must write himself application program and download into main control unit.
What is MASTER/SLAVE of I-8000 Series ? The 8K485.EXE is a SLAVE firmware, it can be download into the main control unit & make it act as a SLAVE device similar to 7000 series. When the I-8000 series(8410/8810) is shipping, it is download with AUTOEXEC.BAT & 8K485.EXE.So the I-8000 series(8410/8810) will automatically execute the 8K485.EXE when the power is applied (INIT* pin OPEN). When the 8410/8810 execute the 8K485.EXE, it is a SLAVE device. If the INIT* pin & INIT* COM pin are short together,user can download new user program into 8410/8810 to make it act as a MASTER device.
When the 8411/8811 is shipping, it is master.Only the MIniOS7 in the main control unit.
How to change the 8410/8810 to a MASTER device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download user's application program & AUTOEXEC.BAT into 8410/8810
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8410/8810 will start to execute user's program & act as a MASTER device.
How to change the 8411/8811 to a Slave device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download 87K485.EXE & AUTOEXEC.BAT into 8411/8811
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8411/8811 will start to execute 87K485.EXE & act as a SLAVE device.